FlippyListRanker list and category pages not found (404)

Home Forums Bugs and Fixes FlippyListRanker list and category pages not found (404)


This topic contains 6 replies, has 3 voices, and was last updated by max max 1 year, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1629


    After installing FlippyListRanker software on my Ubuntu 12.04 server using Apache 2.4 and Perl 5.6, the installation of the database went smooth, and the main pages loaded just fine. The admin CP worked like a charm.

    However, the first problem was the “About”, “Privacy”, “Terms” (etc) pages in the footer did not display using the links. Adding a .php extension in the URL made them work. Later changing .htaccess to automatically supply a .php to an extensionless URL made them work as well.

    However, when list and category page URLs with long names like:
    were generated by the site, and even though the category exists and is approved, it displays only a 404 Page Not Found error.

    I can see this works in the online demo, so I think the FlippyListRanker code is working properly. Is there a special Apache .htaccess configuration needed (mod_rewrite) needed to make this work?

    Best regards,
    Tom Straub



    Hello Support?



    Hey tom,
    I am having the same problems myself, did you get a solution for these?


    Please send us a email with your payment email address in order for us to help you.


    @tomstraub yes you need mod_rewrite enabled. You should first make sure your hosting provider has installed/enabled mod_rewrite. if mod_rewrite is already installed and enabled you should then
    make sure you have uploaded your .htaccess if your in Mac you cannot see the .htaccess. Please read below post if your using a Mac.


    Also you can try adding below code to you .htaccess right after the code
    RewriteEngine on

    RewriteBase /
    RewriteRule ^index\.html?$ / [NC,R,L]


    Dear Support,

    Yes, the mod_rewrite module in Apache is enabled. The “.htaccess” lines you provided, unfortunately, did nothing, probably because the DirectoryIndex is “index.php” not “index.html”.

    After a lot of searching the PHP code and trial and error, the following added to the “.htaccess” file got it working:

    # Add web page handlers
    AcceptPathInfo On
    # For security reasons, Option all cannot be overridden.
    Options +ExecCGI +Includes +IncludesNOEXEC +SymLinksIfOwnerMatch +MultiViews -Indexes
    # Set the default index page
    DirectoryIndex index.php
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^category-([0-9]+)-(.*)$ category.php?cat=$1
    RewriteRule ^list-([0-9]+)-(.*)$ list.php?id=$1
    RewriteRule ^profile-([0-9]+)-(.*)$ profile.php?id=$1
    RewriteRule ^my_lists-([0-9]+)$ my_lists.php?id=$1
    RewriteRule ^edit_list-([0-9]+)$ edit_list.php?id=$1
    RewriteRule ^edit_items-([0-9]+)-([0-9]+)$ edit_list.php?uniq=$1&id=$2
    RewriteRule ^voted_lists-([0-9]+)$ voted_lists.php?id=$1
    • This reply was modified 1 year, 4 months ago by  tomstraub.

    @tomstraub our .htaccess file works with most of the severs out there. But ones in a while severs have different configurations. In this case rewrite rules have to be change in order to work. Anyway I’m glad you figure out the issue. If you need any help just let us know. If you need a fast reply please email us.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.